DEDE织梦__autoload() is deprecated, use spl_autoload_register() instead in报错

织梦dedecms报错:__autoload() is deprecated, use spl_autoload_register() instead in的解决方法

2017年的DEDECMS5.7的版本,但是现在将PHP升级PHP7.2版本后,DEDECMS织梦登陆网站后台,显示提示__autoload() is deprecated, use spl_autoload_register() instead in 295行 出现错误提示两种完美解决方法。

1、DEDECMS升级到2018年1月09日

1-1、改回后台登陆地址目录dede。如果修改后台登陆地址的,改回dede。因为在线升级下载文件会到dede目录。如果没修改过后台登陆dede目录,无须修改

1-2、登陆后台后,点击DEDECMS更新信息里的“进行在线更新”

1-3、下一步,下一不即可。

自动升级
自动升级DEDECMS版本

最后dedecms会自动升级为2018年1月09日。此时就完美彻底兼容php 7.2环境下正常使用dedecms了。

2、降低php版本,推荐降低到php 5.6版本。

如果是宝塔服务器管理后台,登陆后--> 找到对应站点 -> 右侧的“设置” -》切换PHP版本 修改为PHP5.6版本即可。

此方法没有解决彻底问题,推荐使用方法要么彻底重新安装最新dedecms 5.7 sp2 ,2018年1月9日版,要么登陆你网站dede后台 在线轻松更新解决__autoload() is deprecated, use spl_autoload_register() instead in 错误提示。

标签库